https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23357 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org --- Comment #4 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Nick, what about this change: unless ( $effective_mtt eq 'print' and $print_sent == 1 ) { - if ( ($mtt eq 'email' and not scalar @emails_to_use) or ($mtt eq 'sms' and not $data->{smsalertnumber}) ) { + if ( $effective_mtt eq 'print' and not $print_sent ) { push @output_chunks, It makes the code more readable and less error prone, what do you think? -- You are receiving this mail because: You are watching all bug changes.