https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=40424 Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> changed: What |Removed |Added ---------------------------------------------------------------------------- Attachment #184219|0 |1 is obsolete| | --- Comment #8 from Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> --- Created attachment 184555 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=184555&action=edit Bug 40424: Simplify existing code - preparation I wanted to isolate the changes for the query-in-body handling and it made sense to refactor this dupicated code at the same time. So I add this patch for tidying the area in preparation for the other part. Duplicated code gets simplified. To test: 1. Apply the unit tests patch 2. Run: $ ktd --shell k$ prove t/Koha/REST/Plugin/Query.t \ t/db_dependent/api/v1/*.t \ t/db_dependent/Koha/REST/Plugin/ => SUCCESS: Tests pass! 3. Apply this patch 4. Repeat 2 => SUCCESS: Tests pass! 5. Sign off :-D Signed-off-by: Matt Blenkinsop <matt.blenkinsop@openfifth.co.uk> Signed-off-by: Martin Renvoize <martin.renvoize@openfifth.co.uk> -- You are receiving this mail because: You are watching all bug changes.