https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12747 --- Comment #52 from M. Tompsett <mtompset@hotmail.com> --- Comment on attachment 66586 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=66586 Bug 12747 - Add extra column in Z3950 search Review of attachment 66586: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=12747&attachment=66586) ----------------------------------------------------------------- ::: C4/Breeding.pm @@ +365,5 @@
+ my $fieldContent=''; + if ($length > 3){ + my $adSubfield; + for (my $i=0; $i<$length-3; $i++){ + $adSubfield = substr($_, 3+$i, 1);
When you have nested loops, one should avoid $_ and be explicit (on line 359) to improve readability and prevent accidental breakage later. -- You are receiving this mail because: You are watching all bug changes.