https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17960 Bug ID: 17960 Summary: Rename opac_news.new Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: ASSIGNED Severity: normal Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: jonathan.druart@bugs.koha-community.org Reporter: jonathan.druart@bugs.koha-community.org QA Contact: testopia@bugs.koha-community.org The field opac_news.new is very confusing and should be renamed. If you want to access it via Koha::NewsItem you will have trouble: use Koha::News; my $news_item = Koha::News->next; say $news_item->new; => Attempt to bless into a reference at /home/vagrant/kohaclone/Koha/Object.pm line 78. -- You are receiving this mail because: You are watching all bug changes.