https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26351 --- Comment #16 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Sorry Kyle.... * I see a test for barcode_generate, but don't see any code related to this in the rest of the patchset.. does this belong in a different bug? * You're a tad inconsistent with when you call 'barcode_transform'.. sometimes it's prior to a call to 'barcodedecode', sometimes it's just after.. I imagine that it should be just after (and only actually called if 'barcodedecode' is not run (as barcodedecode runs it internally already). * Finally, I wonder about the name of the method 'barcode_transform'.. it made sense prior to splitting the bug in two.. but perhaps it would be clearer/easier for plugin developers to have a different name for the two options.. item_barcode_transform and patron_barcode_transfer perhaps?. I'm continuing with testing, but feedback on the above would be great. -- You are receiving this mail because: You are watching all bug changes.