https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42032 --- Comment #26 from Martin Renvoize (ashimema) <martin.renvoize@openfifth.co.uk> --- Created attachment 198303 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=198303&action=edit Bug 42032: (follow-up) Pretty-render authority info column in log viewer Mirrors bug 42188's biblio log-viewer rendering. Generalise the biblio-only renderCatalogInfo() helper in viewlog.js to also match the "authority <JSON>" prefix introduced by the previous follow-up, and rename it to renderRecordInfo() to reflect its wider scope. The existing fmtJsonValue() helper already handles MiJ's nested arrays of subfield objects, so no rendering changes are needed beyond the regex and name. Test plan: 1. Enable AuthoritiesLog. 2. Create, edit, and delete an authority via the staff UI. 3. Go to Tools -> Log viewer, filter by module=Authorities. 4. Verify: - ADD row's info cell shows just "authority". - MODIFY and DELETE rows' info cells render as a nested list (auth_header columns plus _marc leader + fields array). - Diff column still renders the before/after struct-diff table. 5. Re-check a biblio (CataloguingLog) entry: still renders as before. 6. Re-check a MEMBERS entry: untouched. -- You are receiving this mail because: You are watching all bug changes.