https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27944 --- Comment #86 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Jonathan Druart from comment #84)
1. Missing POD in Koha::ArticleRequest
2. Koha::ArticleRequest->request is not covered by tests
3. Changes to Koha::ArticleRequest->cancel are not covered by tests
4. Koha::ArticleRequests->requested is not covered by tests
4. Not a big deal (not blocker of course) but $reason = $av->lib_opac ? $av->lib_opac : $av->lib if $av; Is more readable (IMO) like: $reason = $av->lib_opac || $av->lib if $av;
Can this be pushed as is? I move the tests to another file in a later bug and can happily add tests. Some already exist on Article requests.t -- You are receiving this mail because: You are watching all bug changes.