https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21073 --- Comment #85 from Kyle M Hall <kyle@bywatersolutions.com> --- Created attachment 90737 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=90737&action=edit Bug 21073: (QA follow-up) Simplify logic This patch simplifies the logic inside GetPlugins so: - It uses Koha::Plugins::Methods instead of plain SQL - It doesn't do more DB calls than needed, by filtering on method in the initial query to Koha::Plugins::Methods. It also relies on the (newly introduced) ->is_enabled method in Koha::Plugins::Base, for better readability. To test: - Run the tests and notice no behaviour changes are introduced. Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io> Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com> -- You are receiving this mail because: You are watching all bug changes.