https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18501 Martin Renvoize <martin.renvoize@ptfs-europe.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Signed Off |In Discussion --- Comment #19 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- OK.. the more I think about this, the more little things I find. 'set_found' is a bad name, as we don't actually trigger any update of the itemlost field and so we're not actually setting the item as found.. we're simply doing a refund if required and leaving the actual update of the itemlost (and itemlost_on) field to the caller. I'm actually starting to think this should be a trigger inside the store routine to ensure we consistently catch it any time 'itemlost' is updated. -- You are receiving this mail because: You are watching all bug changes.