https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32739 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Needs Signoff |In Discussion --- Comment #6 from David Cook <dcook@prosentient.com.au> --- (In reply to Tomás Cohen Arazi from comment #5)
After talking with Martin, I decided to submit this patches the way they are written.
I decided to rename 'userid' => 'identifier' to make it generic enough. I'm open to discuss if you *also* want to be able to specify *userid* and *cardnumber* explicitly, but I think this is the way to go and thus my proposal.
Best regards
I'd be happy for "identifier" to be added in addition to "userid", but I think renaming it is a problematic idea, since "userid" is already in use by third-party systems using the production API. Koha has a bit of a habit of making backwards incompatible changes to its "v1" API... -- You are receiving this mail because: You are watching all bug changes.