https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35310 --- Comment #9 from Victor Grousset/tuxayo <victor@tuxayo.net> ---
Note that when the work was originally done, readingrec.tt was tracking issues (which I believe is all the checkouts of an item)
An issue is the historic name of a checkout. https://wiki.koha-community.org/wiki/Terminology#I That can create confusion when looking at history or places where it's not practical to change ^^" So it's likely the same in that case.
Additional testing to the previous test plans could also be done by visiting the readingrec page to make sure everything is ok: /cgi-bin/koha/members/readingrec.pl?cardnumber=42
Looks good :)
I think the original string "Note: X out of Y renewals have been logged" was a way to let the user now that only X amount of renewals corresponded to the current checkout, out of a Y total, if that is the case then it's not needed anymore. But I'm not 100%, this is confusing.
Looking more at it: the data-renewals attribute changed by these patches is what is used by the `if (data.length < renewals)` in checkout_renewals_modal.js so I'm pretty sure it's rendered obsolete. As for the cleanup it seems to me that it's the following that needs to be removed: checkout_renewals_modal.js: if (data.length < renewals) {...} checkout_renewals.inc: <div id="incomplete" class="alert" style="display:none"></div> What does it looks like to you? And to which degree of certainty? ^^ -- You are receiving this mail because: You are watching all bug changes.