https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17990 --- Comment #1 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Created attachment 59546 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=59546&action=edit Bug 17990: Refactor Perl module versions check The code is duplicated, variable are not set ($_), code is hard to read, not covered by tests and the subroutine has 2 completely different behaviors depending on the presence of the "module" parameter. No need more ti rewrite it. Test plan: - Use koha_perl_deps.pl with the different options (-u -m -a -i) - Go on the about page, "Perl modules" tab You should not see any differences from before and after this patch -- You are receiving this mail because: You are watching all bug changes.