http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11682 Bug ID: 11682 Summary: serials.status is too dependent on magic numbers Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Serials Assignee: koha-bugs@lists.koha-community.org Reporter: gmcharlt@gmail.com QA Contact: testopia@bugs.koha-community.org CC: colin.campbell@ptfs-europe.com The status column in the serials table, which represents the receipt status of a serial issue, uses a slew of magic numbers. This can make it difficult to maintain the code and add new statuses. Ways to address this, ranging from simple to more complex, include: [1] Use named constants. [2] Changing serials.status from an integer to a varchar and using self-describing values, possibly in conjunction with a new authorized value list. [3] Create a new serial_issue_status column to manage the statuses. It might look like this: id INTEGER -- status ID name VARCHAR(255) -- label of status missing BOOLEAN -- whether or not the status should be considered to represent an issue that was never received [4] As with option 3, but allowing staff users to define new statuses. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.