https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27944 --- Comment #29 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- The 'open' function is in both the perl code and the js code, now refers to setting to pending status. I think that this will lead to confusion and potential future bugs. Why not call it pending or set_pending or similar? - return $self->open; + return $self->request; + <a class="ar-open-request" href="#" onclick="HandleMulti( Open, [% id_arg | html %], $(this) ); return false;"> + <i class="fa fa-bars"></i> + Set request as pending + function Open( id, a ) { sub open { my ($self) = @_; $self->status(Koha::ArticleRequest::Status::Pending); -- You are receiving this mail because: You are watching all bug changes.