https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21281 Marcel de Rooy <m.de.rooy@rijksmuseum.nl> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |m.de.rooy@rijksmuseum.nl Status|Signed Off |BLOCKED QA Contact|testopia@bugs.koha-communit |m.de.rooy@rijksmuseum.nl |y.org | --- Comment #15 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- - my $query = "SELECT `$params[0]` FROM $params[1]"; + my $fields_list = $params[0]; If I am not mistaken, params[0] is a single field, not a field list. So the new variable name is confusing. If it would be a list of fields, this code does not look good: + if (index($fields_list, ' ')==-1 && index($fields_list,',')==-1 && $fields_list ne '*') { + $fields_list = "`$fields_list`"; + } If you would pass 'rows, something', it would not add backtics. -- You are receiving this mail because: You are watching all bug changes.