https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=16223 --- Comment #107 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- Looks good to me. FAIL koha-tmpl/intranet-tmpl/prog/en/modules/admin/restrictions.tt FAIL filters missing_filter at line 217 ( [% IF restriction.fee_limit %][% restriction.fee_limit %][% END %]) Added follow-up. - if ($dupe->count) { + if ($dupe->count && $dupe->unblessed->{code} ne $code) { my $dupe = Koha::Patron::Restriction::Types->search( { code => { '!=' => $code }, display_text => $display_text, } ); if ($dupe->count && $dupe->unblessed->{code} ne $code) { Look above. This change is unneeded. Removed it. I was just wondering a bit about the column name fee_limit. The crux to understanding what it does, is this test: $total_due <= $restriction->type->fee_limit But I dont have a better name at hand. Could imagine that this field name is not immediately clear to people. -- You are receiving this mail because: You are watching all bug changes.