https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28026 --- Comment #20 from David Cook <dcook@prosentient.com.au> --- (In reply to Martin Renvoize from comment #18)
Please see discussion and resulting bug 28211 where call_recursive is subsequently removed again in preference to passing references.
I was wondering why call_recursive was copying data rather than passing references hehe. (In reply to Martin Renvoize from comment #19)
Also, In bug 27066 comment 10 I talked about the concept of 'before', 'after' and 'around' as a hook naming convention.. I feel the hook names should be tied to their actions and effects..
So, in many ways I think 'before' should be passed the data prior to an action taking place and it's use should not affect said days, after should be passed the data after the action has taken place and again not affect that data.. around could be used for the case where we want to intercept and alter that data in the plugin... thoughts on such a naming convention would be great.
+1 from me. I use before/after/around with frameworks on other system, and it's very easy. I like the predictability of knowing when before/after/around hooks are called. -- You are receiving this mail because: You are watching all bug changes.