https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27946 --- Comment #57 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Marcel de Rooy from comment #51)
+ $debit_line = $self->account->add_debit( + { + amount => $amount, + user_id => C4::Context->userenv ? C4::Context->userenv->{'number'} : undef,
I would expect $self->borrowernumber here instead of going to context? Note btw that this field (in debit lines) user_id is chosen VERY unfortunate. We already had the mixup on the other report. It should be renamed (but not here).
the 'user_id' parameter accounts for the currently logged user recording the debit. So the staff member that added the debit. I think it is correct to fallback to userenv as it is the accountlines.manager_id attribute. -- You are receiving this mail because: You are watching all bug changes.