http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15206 Alex Arnaud <alex.arnaud@biblibre.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|Failed QA |In Discussion --- Comment #31 from Alex Arnaud <alex.arnaud@biblibre.com> --- (In reply to Jonathan Druart from comment #29)
Whaou, an ajax request looks like a bit overkill imo... Anyway, now it's done.
Quick QA comments: 1/ catch error when retrieving the answer of the ajax request (empty .hint) 2/ CalculateAge should only be done if CheckDate return success (otherwise empty .hint) right
3/ Use string_var.format(number) in JS code to display the string can you be more explicit ?
4/ Why do you use gettext? pass age_month and age_year to the template and let it display/translate the string accordingly I think it's better than use some [% if %]/[% else %] in templates that make them less readable imo. And now we have (thx Julian Maurice) Koha::I18N. Why don't use it ?
5/ I think "year(s)" could be replaced with "year" :) And manage the plural for month/months should not be too difficult. ?
-- You are receiving this mail because: You are watching all bug changes.