https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15524 Kyle M Hall <kyle@bywatersolutions.com> changed: What |Removed |Added ---------------------------------------------------------------------------- Status|In Discussion |Passed QA --- Comment #39 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #38)
Kyle,
Go to "Default checkout, hold and return policy", you do not see "Total holds allowed", fill the other fields, save: default_circ_rules.holdallowed is filled. We could add it to the interface and make it configurable, do not you think?
holdallowed doesn't define how many holds may be placed, it defines what items a patron may place holds on. It's already revealed in the rules editor!
Also if we add "max_holds", maybe we should rename "holdallowed" then.
Again, not the same thing.
After that is done, the code in CanItemBeReserved could be replaced with a call to GetBranchBorrowerCircRule.
Without these changes we add more confusion to the code in my opinion.
I will not have the time to provide such change before the release.
Setting to in discussion to get other QAer opinions on these patches.
Feel free to provide a patch if you think my requests make sense to you.
I think your comment is based on a fundamental misunderstanding of what holdallowed does. If I'm wrong let me know! We could definitely add max_holds to the default_circ_rules table, but that should be done on another bug as it is out of scope for this one. -- You are receiving this mail because: You are watching all bug changes.