https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17168 --- Comment #18 from Nick Clemens <nick@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #16)
1. Indentation Tidied
2. More readable options 3. More readable parameters OK, longer names available
4. I do not think update_category should be a Koha::Patrons method, to me it belongs to Koha::Patron Hmm, I don't know that it does enough to a single patron to be a method, the utility is acting on many at once. I can move if you feel strongly
5. Why? + my $remove_guarantor = ( $to_cat->category_type ne 'C' || $to_cat->category_type ne 'P' ) ? 1 : 0; When this was written adults couldn't have guarantors and we stripped them when updating - I suppose this can be removed?
6. Date handling is not the way to do OK, fixed
-- You are receiving this mail because: You are watching all bug changes.