http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12933 --- Comment #16 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #15)
QA comment: I am quite confuse by this patch. IMO there are some inconsistencies: 1/ I don't understand the usefulness to pass by the template plugin to know if a borrower has overdues or not.
By using a TT plugin, we don't have to modify each and every script that uses the members toolbar.
2/ Why did you move parse_letter to the pm file? A subroutine with the same name exists in advance_notices.pl cronjob script (which uses C4::Overdues too, so introduces a redefinion of it)?
I moved it so we could use the same subroutine in both the cron script and the new script. I'll submit a followup to rename it to parse_overdues_letter
3/ Same for C4::Members::GetOverdues, we already have a GetOverdues subroutine in C4::Overdues.
C4::Members::GetOverdues deals with getting a specific borrowers overdues, and gets more data than C4::Overdues::GetOverdues. They really do two different jobs.
4/ Tests are missing for changes in packages.
Will do! -- You are receiving this mail because: You are watching all bug changes.