https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15894 Bug ID: 15894 Summary: Unify all account fine payment functions Change sponsored?: --- Product: Koha Version: unspecified Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: gmcharlt@gmail.com Reporter: kyle@bywatersolutions.com QA Contact: testopia@bugs.koha-community.org Right now, Koha has four different functions for making payments: recordpayment, makepayment, recordpayment_sellectaccts and makepartialpayment. We should replace these four functions with a single all-singing all-dancing method in the Koha::Namespace. This would help to reduce regressions and make future additions much simpler ( such as my planned re-implementation of account offsets ) and add consistency for logging and whatnot. -- You are receiving this mail because: You are watching all bug changes.