https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17586 --- Comment #14 from Kyle M Hall <kyle@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #13)
(In reply to Kyle M Hall from comment #10)
I would do $patron->account()->balance() with account() returning the Koha::Account object, and balance() returning the account balance. Of course, I'm a fan of being succinct ; )
I am not 100% this change is the right thing to do but we could go like that to start. For now, the Koha::Account module's responsibilities are not clearly defined and it's not easy to guess what it will become.
That's fine. I just wanted to put that thought out. We may have a better notion of where such a method would go after the fact and we can make that change at the end rather then have to modify all the dependent patches. -- You are receiving this mail because: You are watching all bug changes.