http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7430 --- Comment #23 from Paul Poulain <paul.poulain@biblibre.com> --- (In reply to comment #22)
My criticism here is those names are quite long, and I don't think these routines are business logic at all. Are we going to build an inheritance structure such that those are objects under inheriting from the classes above them, or is it just an arbitrary naming scheme. agreed If it's arbitrary and there is no inheritance, then I like Koha::MARCUtils better. I suggested, for Logger.pm to have a Koha::Utils namespace. So Koha::Utils::Marc would easily take place here !
OTOH, it access the database, isn't it ? So will need access to Koha::DB::, and haven't we said something about business logic being the entry point for all db accesses ? -- You are receiving this mail because: You are watching all bug changes.