https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42206 --- Comment #6 from Paul Derscheid <paul.derscheid@lmscloud.de> --- Created attachment 196941 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=196941&action=edit Bug 42206: (follow-up) Rename to /closed_dates, improve efficiency Rename /libraries/{id}/holidays to /libraries/{id}/closed_dates for consistency with existing sub-resource naming (desks, cash_registers). Efficiency: instead of calling $calendar->is_holiday() per day (which re-checks all three data sources each time), access the pre-loaded data structures directly: weekly_closed_days array, day_month_closed_days hash, and _holidays hash. The logic properly handles exceptions (dates marked open despite a weekly/annual closure). Additional fixes: - Add 365-day max range guard - Add missing 401/403 responses in swagger spec - Add request_id_header parameter - Test exception handling (open on normally-closed day) - Remove fragile 'empty defaults' assertion Signed-off-by: Tomás Cohen Arazi <tomascohen@theke.io> Signed-off-by: Paul Derscheid <paul.derscheid@lmscloud.de> -- You are receiving this mail because: You are watching all bug changes.