https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17530 --- Comment #24 from Marcel de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to Jonathan Druart from comment #23)
I have not tested it, just had a quick look. Thats a good start ;)
1. This: Koha::Biblio->may_article_request shows that Koha::Biblio is not the right place to put it. Koha::Object class should not have class methods. Yes, this was arbitrary. I could move it to Koha::ItemType. What do you think?
2. In Koha::IssuingRules, $class_or_self must be named $class Will fix that in a follow-up.
3. The cache is cleared in a very lazy way :) Lazy is good enough here imo.
4. Maybe we do not need may_article_request, but only guess_article_requestable_itemtypes? See point 1.
-- You are receiving this mail because: You are watching all bug changes.