https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42546 Bug ID: 42546 Summary: Unify language in system preferences that refer to Reply-To addresses Initiative type: --- Sponsorship --- status: Product: Koha Version: 24.11 Hardware: All OS: All Status: NEW Severity: trivial Priority: P5 - low Component: System Administration Assignee: koha-bugs@lists.koha-community.org Reporter: david_liddle@sil.org QA Contact: testopia@bugs.koha-community.org CC: gmcharlt@gmail.com Preface: I acknowledge the utility of using a different form, i.e. "ReplyTo", in variables instead of the official message header term "Reply-To". There are discrepancies in the text of system preferences that refer to Reply-To addresses. They can be found in both the staff interface and in the 'explanation' column of the 'systempreferences' table. These differences can make it difficult to find the relevant preferences/variables. (Some quotes below shortened for brevity.) AcquisitionsDefaultReplyTo UI: "Use the reply-to email address ___ when sending acquisitions order and claim notices. If left empty, it will fall back to the first defined address in the following list: library reply-to, library email, ReplytoDefault, KohaAdminEmailAddress." DB" "Default email address used as reply-to for notices sent by the acquisitions module." AddressForFailedOverdueNotices UI: "If left empty then it will fallback to the first defined address in the following list: Library ReplyTo, Library Email, ReplytoDefault and KohaAdminEmailAddress" DB: "If left empty then it will fallback to the first defined address in the following list: Library ReplyTo, Library Email, ReplytoDefault and KohaAdminEmailAddress" emailLibrarianWhenHoldIsPlaced UI: "The first email address set from this list will be used: library reply-to, library email, ReplytoDefault, KohaAdminEmailAddress." (NOTE: Inconsistent also in "first email address set from this list" versus "first defined address in the following list") DB: "If ON, emails the librarian whenever a hold is placed" (NOTE: No reference to Reply-To or the list.) ExpireReservesAutoFillEmail UI: "If no address is defined here, the email will be sent to the library's reply-to address." DB: "If not defined, Koha will fallback to the library reply-to address" ReplytoDefault UI: "Email address to be set as the replyto in emails:" DB: "The default email address to be set as replyto." SerialsDefaultReplyTo UI: "Use the reply-to email address ___ when sending serial claim notices. If left empty, it will fall back to the first defined address in the following list: Library ReplyTo, Library Email, ReplytoDefault, KohaAdminEmailAddress." DB: "Default email address used as reply-to for notices sent by the serials module." Consistent, accurate language and terminology matters, so I suggest dropping the hyphen only in direct references to variables that do not use it. Otherwise, the term should be represented as "Reply-To" as given in the RFC and as shown in a library's settings. It will improve searches and make recognition faster. (The same could be said for Return-Path.) -- You are receiving this mail because: You are watching all bug changes. You are the assignee for the bug.