http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7430 --- Comment #21 from M. de Rooy <m.de.rooy@rijksmuseum.nl> --- (In reply to comment #19)
I'm going to play curmudgeon, criticism without a valid counter suggestion is not useful :) So if not Koha::Utils what would you call it?
A crusty, ill-tempered, and usually old man? ;) I am not sure if that may not be useful [at times], btw.. But let me give it a try: High-level configuration functions like GetMarcFromKohaField and GetAuthType.. GetAuthType looks to me like a candidate for the originally called Koha::DataObject, since it just passes the fields for auth_types table. GetMarcFromKohaField should be moved somewhere within Koha::BusinessLogic or its shorter variant. There could be room there for MARC utilities? Let's say: Koha::BusinessLogic::MarcUtils::GetMarcTagForKohaField. If we do not like MarcUtils after all, another proposal: Koha::BusinessLogic::Administration::GetMarcTagForKohaField. -- You are receiving this mail because: You are watching all bug changes.