https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=37849 David Cook <dcook@prosentient.com.au> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |dcook@prosentient.com.au --- Comment #1 from David Cook <dcook@prosentient.com.au> --- (In reply to Sally Lodico from comment #0)
I suggest there be 2 new permissions that allow editing News items in the staff interface. One permission would be to edit their own library's News e.g. edit_own_news and the other to edit all News items e.g. edit_any_news.
Historically, these types of permissions wouldn't really fit with how we do permissions/authorizations, but "view_borrower_infos_from_any_libraries" has set a precedent for these more complicated permissions. I suppose "edit_own_news" and "edit_any_news" would essentially be the same as "list_borrowers" and "view_borrower_infos_from_any_libraries", but with a better naming convention. Personally, I would think "edit_any_news" should be mutually exclusive with "edit_own_news" but we probably don't need to worry about that at this point. I look forward to seeing other comments, but I think this probably sounds all right. I think it implies a future direction that the permission model needs to go and that's taking into consideration more the "subject" and "object" of the action (ie verb). -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.