https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34219 --- Comment #4 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- (In reply to Pedro Amorim from comment #3)
- Add URLparams as a parameter to getAll
Do you mean we should rename params.params to params.URLparams?
- Have a clear distinction between query parameters and URL parameters in http-client.js (and maybe also somewhere else)
2 separate parameters, not params.URLparams and params.query, is that what you mean?
- Rename getAll to search
On a separate bug please. get => find getAll => search
- Handle default _per_page value
This is done already.
- Likely rename this bug
It depends if we let it sit down or move on fast. We need it quite quickly in master I think, we will certainly need it soon (we need already on bug 32474). -- You are receiving this mail because: You are watching all bug changes.