14 Feb
2023
14 Feb
'23
5:18 p.m.
https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=32898 --- Comment #9 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- (In reply to Paul Derscheid from comment #7)
A more idiomatic way to write
response && response.status === 2XX
would be
response?.status === 2XX ?? false
I think this is easier to read when scanning through the code. As this is a matter of taste, I'll let you be the judge.
I didn't know about that syntax. I am not sure I am ready yet :D
Additionally I don't think you need the return await. You await already in the myFetch function so you can just return.
I noticed that but was lazy to try if removing them was ok. Thanks for confirming! -- You are receiving this mail because: You are watching all bug changes.