https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19382 --- Comment #23 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Yes indeed. My idea was to make the tests more readable, and this: + $amount = 0 if ( $patron->id == $child_2->id && ( $i == 0 || $i == 2 || $i == 4 || $i == 5 || $i == 6 ) ); is something I'd like to avoid :) What about the previous question? (In reply to Jonathan Druart from comment #18)
+ is( $child_1->relationships_debt({ only_this_guarantor => 1, include_guarantors => 0, include_this_patron => 0 }), 0, 'Family debt is correct' );
Is this correct? $child_1 is not a guarantor so I don't think it should follow "only_this_guarantor". I would have expected 10 here, can you confirm?
-- You are receiving this mail because: You are watching all bug changes.