https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=34739 --- Comment #21 from Janusz Kaczmarek <januszop@gmail.com> --- (In reply to Thomas Klausner from comment #19)
I'm not sure how expensive calling C4::Context->preference('IncludeSeeFromInSearches') is, but probably it would be better fetch both sysprefs once, put them into a variable and inside the loop just access those vars:
OK, corrected according to your suggestion. I wanted to make the checking conditional but at the end it should be far better to check in once and remember.
Also maybe $update should be renamed to $update_biblio?
This comes from the old code -- I would prefer not to touch the existing code if not necessary. -- You are receiving this mail because: You are watching all bug changes.