https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17168 Jonathan Druart <jonathan.druart@bugs.koha-community.org> changed: What |Removed |Added ---------------------------------------------------------------------------- CC| |jonathan.druart@bugs.koha-c | |ommunity.org Status|Signed Off |Failed QA --- Comment #16 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- Can you refresh this script a bit please? At first glance, at least: 1. Indentation 2. More readable options 3. More readable parameters 4. I do not think update_category should be a Koha::Patrons method, to me it belongs to Koha::Patron 5. Why? + my $remove_guarantor = ( $to_cat->category_type ne 'C' || $to_cat->category_type ne 'P' ) ? 1 : 0; 6. Date handling is not the way to do -- You are receiving this mail because: You are watching all bug changes.