https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=33080 --- Comment #19 from Martin Renvoize <martin.renvoize@ptfs-europe.com> --- Hmm.. well I liked where the branch was going.. but I wasn't aware of the additional calls we're already making to add_pagination_headers as yet so wasn't aware it was a bit of a faff. However, now I've just reviewed this final patch it feels like a few bits have been missed from the commit. The POD calls a helper `objects.total_from_resultset` but then defines it as `objects.generate_pagination_headers` and inside that new helper we call the non-existing `total_from_resultset`.. that feels like it should just be $result_set->count anyway.. but I'm also not entirely clear on the naming of `add_pagination_headers` and `generate_pagination_headers`.. that sort of feel like synonyms.. I could see it getting confusing down the line. Would you like me to step in and lend a hand here Tomas? -- You are receiving this mail because: You are watching all bug changes.