https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19893 --- Comment #172 from Joonas Kylmälä <joonas.kylmala@helsinki.fi> --- Comment on attachment 78690 --> https://bugs.koha-community.org/bugzilla3/attachment.cgi?id=78690 Bug 19893 - Alternative optimized indexing for Elasticsearch Review of attachment 78690: --> (https://bugs.koha-community.org/bugzilla3/page.cgi?id=splinter.html&bug=19893&attachment=78690) ----------------------------------------------------------------- ::: Koha/SearchEngine/Elasticsearch.pm @@ +309,5 @@
+ my $serialization_format = C4::Context->preference('ElasticsearchMARCSerializationFormat'); + + my @record_documents; + + sub _process_mappings {
This sub could be moved out of the marc_records_to_documents sub so that it could be then also documented @@ +397,5 @@
my $marcflavour = lc C4::Context->preference('marcflavour'); my @rules;
+ sub _field_mappings {
Also I think this sub could benefit from documentation and not being inside get_marc_mapping_rules as there is plenty of other things going already in get_marc_mapping_rules so it would make it easier to follow the code. I tried to make a follow-up patch with documentation but it's going pretty slowly since I have to now gather the intel what each variable actually contains. $mappings: a tuple (the name of the field in elasticsearch index, "options" or rules to modify the field data) $record_document: document to put to Elasticsearch index ... -- You are receiving this mail because: You are watching all bug changes.