https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=31393 --- Comment #21 from Julian Maurice <julian.maurice@biblibre.com> --- (In reply to Marcel de Rooy from comment #20)
I have the feeling that we are trying to solve a Shibboleth issue here on a general level, risking to break other uses where 'content' is involved.
The fact that _read_from_dom_node uses 'content' to pass results in a recursive way makes things a bit harder here. It makes using content sort of reserved keyword. Could be done better. But out of scope here.
With bug 28278 I tried to replicate the behavior of XML::Simple, where 'content' is kind of a reserved keyword. I'm not saying it's the best behavior, but it should explain why it's done this way. The patch on this bug makes Koha::Config behave more closely to what XML::Simple was doing.
Would it be easier to use _content in Shibboleth for now? Do you mean changing the attribute name in $KOHA_CONF from content to _content ?
-- You are receiving this mail because: You are watching all bug changes.