http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15206 --- Comment #32 from Jonathan Druart <jonathan.druart@bugs.koha-community.org> --- (In reply to Alex Arnaud from comment #31)
3/ Use string_var.format(number) in JS code to display the string can you be more explicit ?
git grep '\.format(' will give you some examples.
4/ Why do you use gettext? pass age_month and age_year to the template and let it display/translate the string accordingly I think it's better than use some [% if %]/[% else %] in templates that make them less readable imo. And now we have (thx Julian Maurice) Koha::I18N. Why don't use it ?
You will have to test the plurial/existence of the vars in the pl, it's the same :) There is absolutely no need to use Koha::I18N here. Pass the values to the template and let it displays the strings as it wants.
5/ I think "year(s)" could be replaced with "year" :) And manage the plural for month/months should not be too difficult. ?
if months == 1 then display 'month' elsif months > 1 then display 'months' -- You are receiving this mail because: You are watching all bug changes.