http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5872 --- Comment #29 from Paul Poulain <paul.poulain@biblibre.com> 2011-08-01 14:03:15 UTC --- (In reply to comment #26)
It appears that editing am existing holdrestricted by typing "yes" or "no" resets the rule to 0, which means nothing to me.
The "holds restricted to library" should be drop down selection instead of click/type to edit, like "allow on shelf holds" is.
Patch from Aug, 1st fixes the behaviour : the "Hold restricted to library" is now a drop down selection I can't find how to deal correctly with the display of the result : the value displayed is returned by the webservice. If it returns "Yes" or "No", then that won't be translatable. There is no solution to this problem. (In reply to comment #28)
Some first comments from playing with the new interface:
kf 1) Filter is a bit confusing to use. I didn't know what to put in there at first, but Liz figured it out. You can enter itemtype or category descriptions and it will limit the display to those. It's a cool feature, but I think we may need a hint about it in an updated help file and perhaps a better label for the field.
Comment added to the field in patch from Aug, 1st
kf 2) There is something wrong with systempreference ReservesControlBranch. There is an insert for this systempreference in the patch (+$DBversion = '3.05.00.005';) and it's already in the pref file in master. But I can't find it in the systempreference sql files? It also already present in updatedatabase.pl: 2741 $DBversion = '3.01.00.066';
fixed in Patch from Aug, 1st
kf 3) Fine amount is not formatted nicely, displayed like saved in the database: 1.00000
=> fixed by using the same num_formatter as in acq module, patch from Aug 1st
kf 4) 'Reserves' tab should be named 'holds' tab.
fixed in Patch from Aug, 1st
kf 5) 'Holds restricted to library' is a checkbox. Allow on shelf holds is a yes/now pull down. Why use different elements for boolean values?
=> fixed (see answer to liz comment)
Question: In the old circ matrix it was possible to define that an itemtype can not be placed on hold at all (below circ matrix). How is that done now?
-- Configure bugmail: http://bugs.koha-community.org/bugzilla3/userprefs.cgi?tab=email ------- You are receiving this mail because: ------- You are the QA Contact for the bug.