https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=39526 Bug ID: 39526 Summary: Unify syspref variable names for Elasticsearch Change sponsored?: --- Product: Koha Version: Main Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Searching - Elasticsearch Assignee: koha-bugs@lists.koha-community.org Reporter: domm@plix.at QA Contact: testopia@bugs.koha-community.org Some sysprefs are called "Elasticsearch*" (I can find 4 in the DB), and some are called "ES*" (2 in the DB). Those should probably be unified? select variable from systempreferences where variable like 'ES%' or variable like 'Elastic%' order by 1; +--------------------------------------+ | variable | +--------------------------------------+ | ElasticsearchCrossFields | | ElasticsearchIndexStatus_authorities | | ElasticsearchIndexStatus_biblios | | ElasticsearchMARCFormat | | ESBoostFieldMatch | | ESPreventAutoTruncate | +--------------------------------------+ We have more "Elasticsearch" than "ES", "Elasticsearch" is more self-documenting then "ES", and searching for "ES" in sysprefs finds a lot of false positives, so we should unify to "Elasticsearch*". -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.