https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15494 --- Comment #50 from Nick Clemens <nick@bywatersolutions.com> --- (In reply to Jonathan Druart from comment #39)
1. In tests, prefer Koha::IssuingRules->search->update($what_you_need_to_be_set); instead of the DELETE then INSERT. It makes the changes more readable in my opinion.
I generally agree, but circ rules are messy and this file has the same code existing. Should be refactored as a whole
2. What about "NULL" string values? :)
I think we expect a certain level of input from the user and are fairly thorough here
3. Should not we have the same code for OpacHiddenItems and ItemsDeniedRenewal (and UpdateNotForLoanStatusOnCheckin?) There is also UpdateItemLocationOnCheckin (bug 14576)
The minimum would be a new get_rules_from_prefs sub
Moved to its own sub/module - changes for other prefs should be on their own reports
Ah! Not sure the reason is available in the template tho.
The reasons are stored in the issues table, they should be available to templates -- You are receiving this mail because: You are watching all bug changes.