https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26635 --- Comment #37 from Jonathan Druart <jonathan.druart+koha@gmail.com> --- What's next? Should we go with the proposed patches or think something else? (In reply to Jonathan Druart from comment #29)
What about having it more generic? At least the naming to start.
We will want to "expand" itemtypes as well for instance. Do we really need the whole Koha::AV object or do we finally only need the description?
It's similar to the 'columns_to_str' methods I introduced on bug 27526 (yes Tomas, I know you told me already), where we want to have stringified values of object's attributes.
This comment didn't get a reply, and I still think it's what we need here. A stringified version of codes seem sensible. It will work for AVs, branchcode, itemtypes, etc. However it will bring the problem of translatability (but same problem will appear with the current version). In a first step we only want to support AVs so this problem is for later. -- You are receiving this mail because: You are watching all bug changes.