https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=42719 --- Comment #23 from David Cook <dcook@prosentient.com.au> --- @David Nind: What plan did you use for testing? Test plan: 0. Start up KTD using `ktd --sso` 1. Do NOT apply the patch yet 2. Set up SSO (see https://wiki.koha-community.org/wiki/Testing_SSO) 3. Open a private/incognito window in your browser 4. Go to http://localhost:8080/api/v1/public/oauth/login/test/opac 5. Note you get an error like "There was an error authenticating to external identity provider No user session found" 6. Close the private/incognito window 7. Apply the patch 8. sudo koha-plack --restart kohadev 9. Open a private/incognito window in your browser 10. Go to http://localhost:8080/api/v1/public/oauth/login/test/opac 11. Note that you are redirected to the IdP 12. Log into Keycloak 13. Note that you are redirected back to Koha and you appear to be logged in 14. prove /kohadevbox/koha/t/db_dependent/api/v1/oauth_login.t Bonus points: BP1. Double-check that the state parameter is still used (which it is) BP2. Do the whole thing again but via http:/localhost:8080/cgi-bin/koha/opac-main.pl this time BP3. Note that it's still all good -- You are receiving this mail because: You are watching all bug changes.