https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=30019 Bug ID: 30019 Summary: We should DRY out search_limited (and rename it) Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org We've started adding a few search_limited methods to Koha::PluralClass objects to limit searches to only return patron related rows the current logged in user should be allowed to see. We should a) rename search_limited to search_with_patron_limits (to match search_with_library_limits that already exists) and b) DRY out the code along the lines of Koha::Objects::Limit::Library. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.