https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=35819 --- Comment #31 from Tomás Cohen Arazi <tomascohen@gmail.com> --- (In reply to Jonathan Druart from comment #20)
Re-enqueue is definitely better than the naive sleep approach, great!
It is working nicely in my tests.
However I think we should: 1. apply this change to misc/workers/es_indexer_daemon.pl (ideally have the duplicated code moved to Koha::BackgroundJobs but that's for another day) 2. remove the "Job not found" warnings from the logs if the job is actually processed later. 3. correctly handle "Frame not processed". If we are enqueuing a job without correctly encoding the data (not JSON) we will never ack or nack and the worker will get stuck.
I think I missed a lot on this bug conversation :-P Sorry! -- You are receiving this mail because: You are watching all bug changes.