https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24007 Bug ID: 24007 Summary: Koha::Account::non_issues_charges is badly named Change sponsored?: --- Product: Koha Version: master Hardware: All OS: All Status: NEW Severity: enhancement Priority: P5 - low Component: Architecture, internals, and plumbing Assignee: koha-bugs@lists.koha-community.org Reporter: martin.renvoize@ptfs-europe.com QA Contact: testopia@bugs.koha-community.org The non_issues_charges method name suggests you will be returned a set of charges (Account::Lines) which would block a patrons ability to check out items. In fact, it returns a 'balance' of such charges but includes outstanding credits in the calculation. We should either rename the method to clarify it's use or update the method to return the expectation given it's naming. -- You are receiving this mail because: You are the assignee for the bug. You are watching all bug changes.