https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20271 --- Comment #266 from David Cook <dcook@prosentient.com.au> --- (In reply to Jonathan Druart from comment #264)
(In reply to Nick Clemens from comment #261)
Maybe it is too late to ask this question: Rather than joining items and deleteditems, can we join them into a new table and provide views for both of the old tables? This would prevent breaking reports across the board.
biblio, deletedbiblios => biblios? items,deleteditems => all_items?
This is going to be a big problem for existing users, it is going to be many reports, and it is going to cause disruption. Havign views that keep the reports working would be a huge boon.
Yes Nick, this will be addressed on bug 25921. However, I don't think it's a good idea to rename the table to have an inconsistent name. We could rename biblio to biblio, but items is correct. My opinion is that it should be quite trivial to fix the report in an update DB. * \sitems can be replaced with items_legacy * \sbiblio => biblio_legacy * and so on
That's a good point. I wouldn't trust the report DB update to be 100% effective, but effective enough. Even if someone had to manually update a couple reports here and there with items_legacy or biblio_legacy... having the ability to use those legacy views would be good. -- You are receiving this mail because: You are watching all bug changes.