https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26351 --- Comment #18 from Kyle M Hall <kyle@bywatersolutions.com> ---
* I see a test for barcode_generate, but don't see any code related to this in the rest of the patchset.. does this belong in a different bug?
Yes, it is only used in Bug 26352.
* You're a tad inconsistent with when you call 'barcode_transform'.. sometimes it's prior to a call to 'barcodedecode', sometimes it's just after.. I imagine that it should be just after (and only actually called if 'barcodedecode' is not run (as barcodedecode runs it internally already).
Would it make more sense to replace all the calls *with* calls to barcodedecode? If feels incorrect for barcodedecode to be used inconsistently.
* Finally, I wonder about the name of the method 'barcode_transform'.. it made sense prior to splitting the bug in two.. but perhaps it would be clearer/easier for plugin developers to have a different name for the two options.. item_barcode_transform and patron_barcode_transfer perhaps?.
That is fine by me! -- You are receiving this mail because: You are watching all bug changes.