https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24190 --- Comment #18 from Andrew Isherwood <andrew.isherwood@ptfs-europe.com> --- (In reply to Jonathan Druart from comment #14) Hi Jonathan
1. You really should avoid indentation spaces outside of the block you are editing
It was a while ago, but this was almost certainly my editor. I'm very conscious of irrelevant changes, so I'm sure I wouldn't have done this deliberately. I'll keep a closer eye on it in future.
2. Why are you using the "%010d" format?
Since the data I was storing was pretty small, storing an entire Dumper output felt over the top. However, I have since discovered that a precedent has been set for storing action_log data in JSON, so I will move to using this as it is infinitely more readable than zero padded strings.
3. I don't think we should store formatted dates.
OK, fair enough, I'll change that
4. You should also consider adding tests
OK, I'll look at doing that. I don't think they'll be anything beyond "does this function call logaction with the correct payload", but it's better than nothing -- You are receiving this mail because: You are watching all bug changes.